CVE-2017-18091 Cross-site scripting in Fisheye and Crucible
Administrators can inject arbitrary HTML or JavaScript via backup filenames, potentially leading to code execution or security bypass in Atlassian Fisheye and Crucible.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2017-18091?
CVE-2017-18091 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 16 Feb 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
The admin backupprogress action in Atlassian Fisheye and Crucible before version 4.4.3 (the fixed version for 4.4.x) and before 4.5.0 allows remote attackers with administrative privileges to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the filename of a backup.
Weakness: CWE-79
Which versions are affected by CVE-2017-18091?
It affects 2 products.
Products include Atlassian Crucible, Atlassian Fisheye.
How do I fix CVE-2017-18091?
No fix has been published for CVE-2017-18091 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-18091 being exploited?
There is no known exploitation of CVE-2017-18091 in the wild and no public exploit code.
Other vulnerabilities in Atlassian Crucible
Sources
Also known as GHSA-5ccm-pmf8-387g.