CVE-2017-18092 Cross-site scripting in Crucible

Medium 5.4 Published Updated

Remote attackers can inject arbitrary HTML or JavaScript via snippet comments in Atlassian Crucible, potentially executing code or stealing data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-18092?

CVE-2017-18092 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 19 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The print snippet resource in Atlassian Crucible before version 4.4.3 (the fixed version for 4.4.x) and before 4.5.0 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the contents of a comment on the snippet.

Weakness: CWE-79

Which versions are affected by CVE-2017-18092?

It affects 1 product.

Products include Atlassian Crucible.

How do I fix CVE-2017-18092?

No fix has been published for CVE-2017-18092 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-18092 being exploited?

There is no known exploitation of CVE-2017-18092 in the wild and no public exploit code.

All Atlassian Crucible vulnerabilities

Sources

Also known as GHSA-4r7x-c2f7-5gfh.

Is CVE-2017-18092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free