# CVE-2017-18092: Cross-site scripting in Crucible

> Remote attackers can inject arbitrary HTML or JavaScript via snippet comments in Atlassian Crucible, potentially executing code or stealing data.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Feb 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4r7x-c2f7-5gfh

## What is CVE-2017-18092?

CVE-2017-18092 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 19 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The print snippet resource in Atlassian Crucible before version 4.4.3 (the fixed version for 4.4.x) and before 4.5.0 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the contents of a comment on the snippet.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-18092?

It affects 1 product.


Products: Atlassian Crucible.

## How do I fix CVE-2017-18092?

No fix has been published for CVE-2017-18092 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-18092 being exploited?

There is no known exploitation of CVE-2017-18092 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Crucible

- [CVE-2021-43958](https://insights.sbomify.com/CVE-2021-43958/): Security feature bypass in Crucible (critical 9.8)
- [CVE-2017-16861](https://insights.sbomify.com/CVE-2017-16861/): Code injection in Fisheye and Crucible (critical 9.8)
- [CVE-2017-14591](https://insights.sbomify.com/CVE-2017-14591/): Command injection in Fisheye and Crucible (critical 9.0)
- [CVE-2020-4018](https://insights.sbomify.com/CVE-2020-4018/): Cross-site request forgery in Crucible (high 8.8)
- [CVE-2018-13399](https://insights.sbomify.com/CVE-2018-13399/): Privilege escalation in Fisheye and Crucible (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18092 and fix it if it is affected.

What it is: CVE-2017-18092 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 19 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18092 in the wild and no public exploit code.

Affected product: Atlassian Crucible. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18092/ (Markdown: https://insights.sbomify.com/CVE-2017-18092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18092
- OSV: https://osv.dev/vulnerability/CVE-2017-18092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18092/
Summaries are generated and may contain mistakes; the official description above is the record.
