CVE-2017-18093 Cross-site scripting in Fisheye and Crucible

Medium 4.8 Published Updated

Remote attackers with repository modification permissions can inject arbitrary HTML or JavaScript via the repository location setting in Atlassian Fisheye and Crucible.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-18093?

CVE-2017-18093 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 19 Feb 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Various resources in Atlassian Fisheye and Crucible before version 4.4.3 (the fixed version for 4.4.x) and before 4.5.0 allow remote attackers who have permission to add or modify a repository to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the location setting of a configured repository.

Weakness: CWE-79

Which versions are affected by CVE-2017-18093?

It affects 2 products.

Products include Atlassian Crucible, Atlassian Fisheye.

How do I fix CVE-2017-18093?

No fix has been published for CVE-2017-18093 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-18093 being exploited?

There is no known exploitation of CVE-2017-18093 in the wild and no public exploit code.

All Atlassian Crucible vulnerabilities

Sources

Also known as GHSA-5j87-vc56-frp3.

Is CVE-2017-18093 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free