# CVE-2017-18095: Missing authorization in Crucible

> Remote attackers can comment on unauthorized snippets in Atlassian Crucible due to improper authorization checks.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-49jr-p97x-4c27

## What is CVE-2017-18095?

CVE-2017-18095 is a medium-severity missing authorization vulnerability in Atlassian Crucible, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SnippetRPCServiceImpl class in Atlassian Crucible before version 4.5.1 (the fixed version 4.5.x) and before 4.6.0 allows remote attackers to comment on snippets they do not have authorization to access via an improper authorization vulnerability.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2017-18095?

It affects 1 product.


Products: Atlassian Crucible.

## How do I fix CVE-2017-18095?

No fix has been published for CVE-2017-18095 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-18095 being exploited?

There is no known exploitation of CVE-2017-18095 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Crucible

- [CVE-2021-43958](https://insights.sbomify.com/CVE-2021-43958/): Security feature bypass in Crucible (critical 9.8)
- [CVE-2017-16861](https://insights.sbomify.com/CVE-2017-16861/): Code injection in Fisheye and Crucible (critical 9.8)
- [CVE-2017-14591](https://insights.sbomify.com/CVE-2017-14591/): Command injection in Fisheye and Crucible (critical 9.0)
- [CVE-2020-4018](https://insights.sbomify.com/CVE-2020-4018/): Cross-site request forgery in Crucible (high 8.8)
- [CVE-2018-13399](https://insights.sbomify.com/CVE-2018-13399/): Privilege escalation in Fisheye and Crucible (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18095 and fix it if it is affected.

What it is: CVE-2017-18095 is a medium-severity missing authorization vulnerability in Atlassian Crucible, published on 19 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18095 in the wild and no public exploit code.

Affected product: Atlassian Crucible. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18095/ (Markdown: https://insights.sbomify.com/CVE-2017-18095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18095
- OSV: https://osv.dev/vulnerability/CVE-2017-18095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18095/
Summaries are generated and may contain mistakes; the official description above is the record.
