CVE-2017-18121 SimpleSAMLphp XSS Vulnerability
An attacker can execute arbitrary JavaScript in a victim's browser via crafted links in the SimpleSAMLphp consentAdmin module.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-18121?
CVE-2017-18121 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.
Weakness: CWE-79
Which versions are affected by CVE-2017-18121?
2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/simplesamlphp Packagist | From 1.12.0 | 1.14.16 |
simplesamlphp/simplesamlphp Packagist | From 1.12.0 | 1.14.16 |
Products include Debian Debian Linux, Simplesamlphp Simplesamlphp.
How do I fix CVE-2017-18121?
Upgrade simplesamlphp/simplesamlphp to 1.14.16 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-18121 being exploited?
There is no known exploitation of CVE-2017-18121 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-18121, GHSA-fv7m-wc3v-wr3w, UBUNTU-CVE-2017-18121.