CVE-2017-18122 SimpleSAMLphp Signature validation bypass
Attackers can impersonate users by exploiting signature validation flaws in SAML responses, allowing unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18122?
CVE-2017-18122 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. A SimpleSAMLphp Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.
Weakness: CWE-347
Which versions are affected by CVE-2017-18122?
2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/simplesamlphp Packagist | All versions | 1.14.17 |
simplesamlphp/simplesamlphp Packagist | All versions | 1.14.17 |
Products include Debian Debian Linux, Simplesamlphp Simplesamlphp.
How do I fix CVE-2017-18122?
Upgrade simplesamlphp/simplesamlphp to 1.14.17 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-18122 being exploited?
There is no known exploitation of CVE-2017-18122 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-18122, GHSA-j4qf-3w33-8cgc, UBUNTU-CVE-2017-18122.