# CVE-2017-18122: SimpleSAMLphp Signature validation bypass

> Attackers can impersonate users by exploiting signature validation flaws in SAML responses, allowing unauthorized access to protected resources.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18122, GHSA-j4qf-3w33-8cgc, UBUNTU-CVE-2017-18122

## What is CVE-2017-18122?

CVE-2017-18122 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. A SimpleSAMLphp Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2017-18122?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.17 |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.17 |

Products: Debian Debian Linux, Simplesamlphp Simplesamlphp.

## How do I fix CVE-2017-18122?

Upgrade simplesamlphp/simplesamlphp to 1.14.17 or later.

## Is CVE-2017-18122 being exploited?

There is no known exploitation of CVE-2017-18122 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18122 and fix it if it is affected.

What it is: CVE-2017-18122 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 2 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18122 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.17
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18122/ (Markdown: https://insights.sbomify.com/CVE-2017-18122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18122
- OSV: https://osv.dev/vulnerability/CVE-2017-18122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18122/
Summaries are generated and may contain mistakes; the official description above is the record.
