{"answers":{"affected":"2 open source packages ship an affected version, including moment. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-18214 in the wild and no public exploit code.","fix":"Upgrade moment to 2.19.3 or later.","what":"CVE-2017-18214 is a high-severity denial of service vulnerability in Tenable Nessus, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18214 and fix it if it is affected.\n\nWhat it is: CVE-2017-18214 is a high-severity denial of service vulnerability in Tenable Nessus, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moment (npm): affected all versions; fixed in 2.19.3\n- moment (npm): affected all versions; fixed in 2.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18214/ (Markdown: https://insights.sbomify.com/CVE-2017-18214/index.md)","id":"CVE-2017-18214","markdown":"https://insights.sbomify.com/CVE-2017-18214/index.md","name":"CVE-2017-18214","record":{"aliases":["AZL-32178","AZL-41019","DEBIAN-CVE-2017-18214","GHSA-446m-mv8f-q348","ROOT-APP-NPM-CVE-2017-18214","UBUNTU-CVE-2017-18214"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js date library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the moment library by submitting crafted date strings that trigger excessive CPU usage.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moment","vendor":"momentjs"},{"product":"nessus","vendor":"tenable"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in moment","id":"CVE-2017-18214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"tenable:nessus","products":["tenable:nessus"],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-18215"},"packages":[{"ecosystem":"npm","fixed":["2.19.3"],"introduced":["0"],"last_affected":[],"package":"moment","purl":null,"source":"GHSA-446m-mv8f-q348"},{"ecosystem":"npm","fixed":["2.19.3"],"introduced":["0"],"last_affected":[],"package":"moment","purl":"pkg:npm/moment","source":"GHSA-446m-mv8f-q348"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2017-18213"},"products":["n/a"],"published":"2018-03-04","related":[{"cvss_score":6.5,"headline":"Regular Expression Denial of Service in moment","id":"CVE-2016-4055","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using the moment library by submitting crafted date strings that trigger excessive CPU usage.","url":"https://insights.sbomify.com/CVE-2017-18214/"}