# CVE-2017-18214: Regular Expression Denial of Service in moment

> Attackers can cause denial of service in applications using the moment library by submitting crafted date strings that trigger excessive CPU usage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** AZL-32178, AZL-41019, DEBIAN-CVE-2017-18214, GHSA-446m-mv8f-q348, ROOT-APP-NPM-CVE-2017-18214, UBUNTU-CVE-2017-18214

## What is CVE-2017-18214?

CVE-2017-18214 is a high-severity denial of service vulnerability in Tenable Nessus, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-18214?

2 open source packages ship an affected version, including moment. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moment` | npm | All versions | 2.19.3 |
| `moment` | npm | All versions | 2.19.3 |

Products: Momentjs Moment, Tenable Nessus.

## How do I fix CVE-2017-18214?

Upgrade moment to 2.19.3 or later.

## Is CVE-2017-18214 being exploited?

There is no known exploitation of CVE-2017-18214 in the wild and no public exploit code.

## Other vulnerabilities in Tenable Nessus

- [CVE-2016-4055](https://insights.sbomify.com/CVE-2016-4055/): Regular Expression Denial of Service in moment (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18214 and fix it if it is affected.

What it is: CVE-2017-18214 is a high-severity denial of service vulnerability in Tenable Nessus, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18214 in the wild and no public exploit code.

Affected packages and fixed versions:
- moment (npm): affected all versions; fixed in 2.19.3
- moment (npm): affected all versions; fixed in 2.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18214/ (Markdown: https://insights.sbomify.com/CVE-2017-18214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18214
- OSV: https://osv.dev/vulnerability/CVE-2017-18214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18214/
Summaries are generated and may contain mistakes; the official description above is the record.
