CVE-2017-18264 phpMyAdmin Improper Privilege Management
Attackers can bypass password restrictions to log in as users without passwords in phpMyAdmin due to PHP substr behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18264?
CVE-2017-18264 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 1 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.
Which versions are affected by CVE-2017-18264?
8 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.20 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.20 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 to 4.4.15.10 | None |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 to 4.4.15.10 | None |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 to 4.6.6 | None |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 to 4.6.6 | None |
2 more packages
phpmyadmin/phpmyadmin Packagist | From 4.7.0-beta1 | 4.7.0 |
phpmyadmin/phpmyadmin Packagist | From 4.7.0-beta1 | 4.7.0 |
Products include Debian Debian Linux, Phpmyadmin Phpmyadmin.
How do I fix CVE-2017-18264?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.20 or 4.7.0.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-18264 being exploited?
There is no known exploitation of CVE-2017-18264 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-18264, GHSA-5868-g58j-vrj5, UBUNTU-CVE-2017-18264.