{"answers":{"affected":"8 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-18264 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.20 or 4.7.0.","what":"CVE-2017-18264 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 1 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18264 and fix it if it is affected.\n\nWhat it is: CVE-2017-18264 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 1 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18264 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.20\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.20\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0 up to 4.4.15.10; no fix listed\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0 up to 4.4.15.10; no fix listed\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0 up to 4.6.6; no fix listed\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0 up to 4.6.6; no fix listed\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.7.0-beta1; fixed in 4.7.0\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.7.0-beta1; fixed in 4.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18264/ (Markdown: https://insights.sbomify.com/CVE-2017-18264/index.md)","id":"CVE-2017-18264","markdown":"https://insights.sbomify.com/CVE-2017-18264/index.md","name":"CVE-2017-18264","record":{"aliases":["DEBIAN-CVE-2017-18264","GHSA-5868-g58j-vrj5","UBUNTU-CVE-2017-18264"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Attackers can bypass password restrictions to log in as users without passwords in phpMyAdmin due to PHP substr behavior.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Improper Privilege Management","id":"CVE-2017-18264","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","phpmyadmin:phpmyadmin"],"type":"auth_bypass","year":"2017"},"n_packages":8,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-18265"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.20"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":["4.0.10.20"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.4.0"],"last_affected":["4.4.15.10"],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.4.0"],"last_affected":["4.4.15.10"],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.6.0"],"last_affected":["4.6.6"],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.6.0"],"last_affected":["4.6.6"],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":["4.7.0"],"introduced":["4.7.0-beta1"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5868-g58j-vrj5"},{"ecosystem":"Packagist","fixed":["4.7.0"],"introduced":["4.7.0-beta1"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5868-g58j-vrj5"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-18263"},"products":["n/a"],"published":"2018-05-01","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass password restrictions to log in as users without passwords in phpMyAdmin due to PHP substr behavior.","url":"https://insights.sbomify.com/CVE-2017-18264/"}