# CVE-2017-18264: phpMyAdmin Improper Privilege Management

> Attackers can bypass password restrictions to log in as users without passwords in phpMyAdmin due to PHP substr behavior.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18264, GHSA-5868-g58j-vrj5, UBUNTU-CVE-2017-18264

## What is CVE-2017-18264?

CVE-2017-18264 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 1 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

## Which versions are affected by CVE-2017-18264?

8 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.20 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.20 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 to 4.4.15.10 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 to 4.4.15.10 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 to 4.6.6 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 to 4.6.6 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.7.0-beta1 | 4.7.0 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.7.0-beta1 | 4.7.0 |

Products: Debian Debian Linux, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2017-18264?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.20 or 4.7.0.

## Is CVE-2017-18264 being exploited?

There is no known exploitation of CVE-2017-18264 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18264 and fix it if it is affected.

What it is: CVE-2017-18264 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 1 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18264 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.20
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.20
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0 up to 4.4.15.10; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0 up to 4.4.15.10; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0 up to 4.6.6; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0 up to 4.6.6; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.7.0-beta1; fixed in 4.7.0
- phpmyadmin/phpmyadmin (Packagist): affected from 4.7.0-beta1; fixed in 4.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18264/ (Markdown: https://insights.sbomify.com/CVE-2017-18264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18264
- OSV: https://osv.dev/vulnerability/CVE-2017-18264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18264/
Summaries are generated and may contain mistakes; the official description above is the record.
