{"answers":{"affected":"2 open source packages ship an affected version, including nzedb/nzedb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-18286 in the wild and no public exploit code.","fix":"Upgrade nzedb/nzedb to 0.8.0.0 or later.","what":"CVE-2017-18286 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-18286 and fix it if it is affected.\n\nWhat it is: CVE-2017-18286 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-18286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nzedb/nzedb (Packagist): affected all versions; fixed in 0.8.0.0\n- nzedb/nzedb (Packagist): affected all versions; fixed in 0.8.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18286/ (Markdown: https://insights.sbomify.com/CVE-2017-18286/index.md)","id":"CVE-2017-18286","markdown":"https://insights.sbomify.com/CVE-2017-18286/index.md","name":"CVE-2017-18286","record":{"aliases":["GHSA-h847-63fg-vm6c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"nZEDb web application","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in nZEDb allows attackers to inject malicious scripts via the 404 error page, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nzedb","vendor":"nzedb"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"nZEDb v0.7.3.3 has XSS in the 404 error page.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"nZEDb Cross-site Scripting (XSS) in the 404 error page","id":"CVE-2017-18286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2017-18287"},"packages":[{"ecosystem":"Packagist","fixed":["0.8.0.0"],"introduced":["0"],"last_affected":[],"package":"nzedb/nzedb","purl":null,"source":"GHSA-h847-63fg-vm6c"},{"ecosystem":"Packagist","fixed":["0.8.0.0"],"introduced":["0"],"last_affected":[],"package":"nzedb/nzedb","purl":"pkg:composer/nzedb/nzedb","source":"GHSA-h847-63fg-vm6c"}],"prev":{"headline":"Misconfiguration in n/a","id":"CVE-2017-18285"},"products":["n/a"],"published":"2018-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in nZEDb allows attackers to inject malicious scripts via the 404 error page, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-18286/"}