# CVE-2017-18286: nZEDb Cross-site Scripting (XSS) in the 404 error page

> Cross-site scripting vulnerability in nZEDb allows attackers to inject malicious scripts via the 404 error page, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h847-63fg-vm6c

## What is CVE-2017-18286?

CVE-2017-18286 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

nZEDb v0.7.3.3 has XSS in the 404 error page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-18286?

2 open source packages ship an affected version, including nzedb/nzedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nzedb/nzedb` | Packagist | All versions | 0.8.0.0 |
| `nzedb/nzedb` | Packagist | All versions | 0.8.0.0 |

Products: Nzedb Nzedb.

## How do I fix CVE-2017-18286?

Upgrade nzedb/nzedb to 0.8.0.0 or later.

## Is CVE-2017-18286 being exploited?

There is no known exploitation of CVE-2017-18286 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18286 and fix it if it is affected.

What it is: CVE-2017-18286 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18286 in the wild and no public exploit code.

Affected packages and fixed versions:
- nzedb/nzedb (Packagist): affected all versions; fixed in 0.8.0.0
- nzedb/nzedb (Packagist): affected all versions; fixed in 0.8.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18286/ (Markdown: https://insights.sbomify.com/CVE-2017-18286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18286
- OSV: https://osv.dev/vulnerability/CVE-2017-18286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18286/
Summaries are generated and may contain mistakes; the official description above is the record.
