{"answers":{"affected":"3 open source packages ship an affected version, including pyyaml and PyYAML. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-18342 in the wild and no public exploit code.","fix":"Upgrade pyyaml to 5.1 or later.","what":"CVE-2017-18342 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 27 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18342 and fix it if it is affected.\n\nWhat it is: CVE-2017-18342 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 27 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18342 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyyaml (PyPI): affected all versions; fixed in 5.1\n- pyyaml (PyPI): affected all versions; fixed in 5.1\n- PyYAML (PyPI): affected all versions; fixed in 5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18342/ (Markdown: https://insights.sbomify.com/CVE-2017-18342/index.md)","id":"CVE-2017-18342","markdown":"https://insights.sbomify.com/CVE-2017-18342/index.md","name":"CVE-2017-18342","record":{"aliases":["DEBIAN-CVE-2017-18342","GHSA-rprw-h62v-c2w7","MGASA-2019-0125","PYSEC-2018-49","UBUNTU-CVE-2017-18342","openSUSE-SU-2024:11247-1","openSUSE-SU-2024:14152-1","openSUSE-SU-2026:11192-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python YAML library","requires_auth":"none","summary":"Attackers can execute arbitrary code by providing malicious YAML data to the unsafe load function in PyYAML.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pyyaml","vendor":"pyyaml"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyYAML insecurely deserializes YAML strings leading to arbitrary code execution","id":"CVE-2017-18342","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"deserialization","year":"2017"},"n_packages":5,"n_references":9,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-18343"},"packages":[{"ecosystem":"PyPI","fixed":["5.1"],"introduced":["0"],"last_affected":[],"package":"PyYAML","purl":null,"source":"GHSA-rprw-h62v-c2w7"},{"ecosystem":"PyPI","fixed":["5.1"],"introduced":["0"],"last_affected":[],"package":"pyyaml","purl":"pkg:pypi/pyyaml","source":"GHSA-rprw-h62v-c2w7"},{"ecosystem":"PyPI","fixed":["5.1"],"introduced":["0"],"last_affected":[],"package":"pyyaml","purl":"pkg:pypi/pyyaml","source":"PYSEC-2018-49"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.7.1-1.3"],"introduced":["0"],"last_affected":[],"package":"python-openapi-spec-validator","purl":"pkg:rpm/opensuse/python-openapi-spec-validator\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14152-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-openapi-spec-validator","purl":"pkg:rpm/opensuse/python-openapi-spec-validator\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11192-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-18341"},"products":["n/a"],"published":"2018-06-27","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by providing malicious YAML data to the unsafe load function in PyYAML.","url":"https://insights.sbomify.com/CVE-2017-18342/"}