# CVE-2017-18342: PyYAML insecurely deserializes YAML strings leading to arbitrary code execution

> Attackers can execute arbitrary code by providing malicious YAML data to the unsafe load function in PyYAML.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18342, GHSA-rprw-h62v-c2w7, MGASA-2019-0125, PYSEC-2018-49, UBUNTU-CVE-2017-18342, openSUSE-SU-2024:11247-1, openSUSE-SU-2024:14152-1, openSUSE-SU-2026:11192-1

## What is CVE-2017-18342?

CVE-2017-18342 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 27 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-18342?

3 open source packages ship an affected version, including pyyaml and PyYAML. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyyaml` | PyPI | All versions | 5.1 |
| `pyyaml` | PyPI | All versions | 5.1 |
| `PyYAML` | PyPI | All versions | 5.1 |
| `python-openapi-spec-validator` | openSUSE:Tumbleweed | All versions | 0.7.1-1.3 |
| `python-openapi-spec-validator` | openSUSE:Tumbleweed | All versions | 0.9.0-1.1 |

Products: Fedoraproject Fedora, Pyyaml Pyyaml.

## How do I fix CVE-2017-18342?

Upgrade pyyaml to 5.1 or later.

## Is CVE-2017-18342 being exploited?

There is no known exploitation of CVE-2017-18342 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18342 and fix it if it is affected.

What it is: CVE-2017-18342 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 27 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18342 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyyaml (PyPI): affected all versions; fixed in 5.1
- pyyaml (PyPI): affected all versions; fixed in 5.1
- PyYAML (PyPI): affected all versions; fixed in 5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18342/ (Markdown: https://insights.sbomify.com/CVE-2017-18342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18342
- OSV: https://osv.dev/vulnerability/CVE-2017-18342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18342/
Summaries are generated and may contain mistakes; the official description above is the record.
