# CVE-2017-18349: Improper Input Validation in alilibaba:fastjson

> Remote attackers can execute arbitrary code via crafted JSON requests due to unsafe deserialization in the Fastjson library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-xjrr-xv9m-4pw5

## What is CVE-2017-18349?

CVE-2017-18349 is a critical unsafe deserialization vulnerability in n/a, published on 23 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

parseObject in Fastjson before 1.2.25, as used in FastjsonEngine in Pippo 1.11.0 and other products, allows remote attackers to execute arbitrary code via a crafted JSON request, as demonstrated by a crafted rmi:// URI in the dataSourceName field of HTTP POST data to the Pippo /json URI, which is mishandled in AjaxApplication.java.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-18349?

4 open source packages ship an affected version, including com.alibaba:fastjson and ro.pippo:pippo-fastjson. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.alibaba:fastjson` | Maven | All versions | 1.2.31 |
| `com.alibaba:fastjson` | Maven | All versions | 1.2.31 |
| `ro.pippo:pippo-fastjson` | Maven | All versions | 1.12.0 |
| `ro.pippo:pippo-fastjson` | Maven | All versions | 1.12.0 |

Products: Alibaba Fastjson, Pippo Pippo.

## How do I fix CVE-2017-18349?

Upgrade com.alibaba:fastjson to 1.2.31 or later.

## Is CVE-2017-18349 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18349 exists.

Public exploit code:

- https://github.com/h0cksr/Fastjson--CVE-2017-18349- (github_poc): https://github.com/h0cksr/Fastjson--CVE-2017-18349-
- https://github.com/Dungsocool/CVE-2017-18349 (github_poc): https://github.com/Dungsocool/CVE-2017-18349
- Fastjson Insecure Deserialization - Remote Code Execution (nuclei): http/cves/2017/CVE-2017-18349.yaml

## Other vulnerabilities in n/a

- [CVE-2022-25845](https://insights.sbomify.com/CVE-2022-25845/): Deserialization of Untrusted Data (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18349 and fix it if it is affected.

What it is: CVE-2017-18349 is a critical unsafe deserialization vulnerability in n/a, published on 23 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18349 exists.

Affected packages and fixed versions:
- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.31
- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.31
- ro.pippo:pippo-fastjson (Maven): affected all versions; fixed in 1.12.0
- ro.pippo:pippo-fastjson (Maven): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18349/ (Markdown: https://insights.sbomify.com/CVE-2017-18349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18349
- OSV: https://osv.dev/vulnerability/CVE-2017-18349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18349/
Summaries are generated and may contain mistakes; the official description above is the record.
