# CVE-2017-18353: rendertron can remotely shut down Chrome instance

> An unauthorized remote attacker can shut down the Chrome instance by accessing an unprotected route, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4q69-q4q7-x82c

## What is CVE-2017-18353?

CVE-2017-18353 is a high-severity missing authorization vulnerability in n/a, published on 17 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rendertron 1.0.0 includes an _ah/stop route to shutdown the Chrome instance responsible for serving render requests to all users. Visiting this route with a GET request allows any unauthorized remote attacker to disable the core service of the application.

## Which versions are affected by CVE-2017-18353?

2 open source packages ship an affected version, including rendertron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rendertron` | npm | All versions | 1.1.0 |
| `rendertron` | npm | All versions | 1.1.0 |

Products: Google Rendertron.

## How do I fix CVE-2017-18353?

Upgrade rendertron to 1.1.0 or later.

## Is CVE-2017-18353 being exploited?

There is no known exploitation of CVE-2017-18353 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-18354](https://insights.sbomify.com/CVE-2017-18354/): rendertron LFI vulnerability (high 7.5)
- [CVE-2017-18355](https://insights.sbomify.com/CVE-2017-18355/): Rendertron discloses absolute paths of files (high 7.5)
- [CVE-2017-18352](https://insights.sbomify.com/CVE-2017-18352/): rendertron XSS vulnerability (medium 6.1)
- [CVE-2020-8902](https://insights.sbomify.com/CVE-2020-8902/): SSRF in Rendertron (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18353 and fix it if it is affected.

What it is: CVE-2017-18353 is a high-severity missing authorization vulnerability in n/a, published on 17 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18353 in the wild and no public exploit code.

Affected packages and fixed versions:
- rendertron (npm): affected all versions; fixed in 1.1.0
- rendertron (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18353/ (Markdown: https://insights.sbomify.com/CVE-2017-18353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18353
- OSV: https://osv.dev/vulnerability/CVE-2017-18353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18353/
Summaries are generated and may contain mistakes; the official description above is the record.
