# CVE-2017-18357: Shopware XXE Vulnerability

> Attackers can exploit PHP object instantiation to trigger XXE, potentially reading sensitive data or executing code in Shopware.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6m27-7cqj-2mxw

## What is CVE-2017-18357?

CVE-2017-18357 is a medium-severity vulnerability in Shopware Shopware, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware before 5.3.4 has a PHP Object Instantiation issue via the sort parameter to the loadPreviewAction() method of the Shopware_Controllers_Backend_ProductStream controller, with resultant XXE via instantiation of a SimpleXMLElement object.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2017-18357?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 5.3.4 |
| `shopware/shopware` | Packagist | All versions | 5.3.4 |

Products: Shopware Shopware.

## How do I fix CVE-2017-18357?

Upgrade shopware/shopware to 5.3.4 or later.

## Is CVE-2017-18357 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18357 exists.

Public exploit code:

- Shopware createInstanceFromNamedArguments PHP Object Instantiation RCE (metasploit)
- Shopware - createInstanceFromNamedArguments PHP Object Instantiation Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18357 and fix it if it is affected.

What it is: CVE-2017-18357 is a medium-severity vulnerability in Shopware Shopware, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18357 exists.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 5.3.4
- shopware/shopware (Packagist): affected all versions; fixed in 5.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18357/ (Markdown: https://insights.sbomify.com/CVE-2017-18357/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18357
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18357
- OSV: https://osv.dev/vulnerability/CVE-2017-18357

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18357/
Summaries are generated and may contain mistakes; the official description above is the record.
