{"answers":{"affected":"3 open source packages ship an affected version, including colander. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-18361 in the wild and no public exploit code.","fix":"Upgrade colander to 1.7.0 or later.","what":"CVE-2017-18361 is a high-severity denial of service vulnerability in n/a, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18361 and fix it if it is affected.\n\nWhat it is: CVE-2017-18361 is a high-severity denial of service vulnerability in n/a, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18361 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- colander (PyPI): affected all versions; fixed in 1.7.0\n- colander (PyPI): affected all versions; fixed in 1.7.0\n- colander (PyPI): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18361/ (Markdown: https://insights.sbomify.com/CVE-2017-18361/index.md)","id":"CVE-2017-18361","markdown":"https://insights.sbomify.com/CVE-2017-18361/index.md","name":"CVE-2017-18361","record":{"aliases":["GHSA-rv95-4wxj-6fqq","PYSEC-2019-167","UBUNTU-CVE-2017-18361","openSUSE-SU-2024:11222-1","openSUSE-SU-2024:14136-1","openSUSE-SU-2026:12004-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python validation library","requires_auth":"none","summary":"An attacker can cause a denial of service in the Pylons Colander library by submitting a URL with an unclosed parenthesis, triggering an infinite loop.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"colander","vendor":"pylonsproject"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pylons Colander Denial of Service vulnerability","id":"CVE-2017-18361","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":5,"n_references":2,"next":{"headline":"Kaseya VSA SQL Injection","id":"CVE-2017-18362"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"colander","purl":null,"source":"GHSA-rv95-4wxj-6fqq"},{"ecosystem":"PyPI","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"colander","purl":"pkg:pypi/colander","source":"GHSA-rv95-4wxj-6fqq"},{"ecosystem":"PyPI","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"colander","purl":"pkg:pypi/colander","source":"PYSEC-2019-167"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0-1.3"],"introduced":["0"],"last_affected":[],"package":"python-colander","purl":"pkg:rpm/opensuse/python-colander\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14136-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0-2.4"],"introduced":["0"],"last_affected":[],"package":"python-colander","purl":"pkg:rpm/opensuse/python-colander\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12004-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2017-18360"},"products":["n/a"],"published":"2019-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in the Pylons Colander library by submitting a URL with an unclosed parenthesis, triggering an infinite loop.","url":"https://insights.sbomify.com/CVE-2017-18361/"}