# CVE-2017-18361: Pylons Colander Denial of Service vulnerability

> An attacker can cause a denial of service in the Pylons Colander library by submitting a URL with an unclosed parenthesis, triggering an infinite loop.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rv95-4wxj-6fqq, PYSEC-2019-167, UBUNTU-CVE-2017-18361, openSUSE-SU-2024:11222-1, openSUSE-SU-2024:14136-1, openSUSE-SU-2026:12004-1

## What is CVE-2017-18361?

CVE-2017-18361 is a high-severity denial of service vulnerability in n/a, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2017-18361?

3 open source packages ship an affected version, including colander. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `colander` | PyPI | All versions | 1.7.0 |
| `colander` | PyPI | All versions | 1.7.0 |
| `colander` | PyPI | All versions | 1.7.0 |
| `python-colander` | openSUSE:Tumbleweed | All versions | 2.0-1.3 |
| `python-colander` | openSUSE:Tumbleweed | All versions | 2.0-2.4 |

Products: Pylonsproject Colander.

## How do I fix CVE-2017-18361?

Upgrade colander to 1.7.0 or later.

## Is CVE-2017-18361 being exploited?

There is no known exploitation of CVE-2017-18361 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18361 and fix it if it is affected.

What it is: CVE-2017-18361 is a high-severity denial of service vulnerability in n/a, published on 1 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18361 in the wild and no public exploit code.

Affected packages and fixed versions:
- colander (PyPI): affected all versions; fixed in 1.7.0
- colander (PyPI): affected all versions; fixed in 1.7.0
- colander (PyPI): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18361/ (Markdown: https://insights.sbomify.com/CVE-2017-18361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18361
- OSV: https://osv.dev/vulnerability/CVE-2017-18361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18361/
Summaries are generated and may contain mistakes; the official description above is the record.
