# CVE-2017-18366: Subrion CMS vulnerable to CSRF in blog/delete

> Attackers can trick authenticated users into deleting blog posts via CSRF in Subrion CMS.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c939-g732-48r8

## What is CVE-2017-18366?

CVE-2017-18366 is a high-severity vulnerability in n/a, published on 12 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Subrion CMS 4.1.5 has CSRF in blog/delete/.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-18366?

2 open source packages ship an affected version, including intelliants/subrion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `intelliants/subrion` | Packagist | All versions | 4.2.1 |
| `intelliants/subrion` | Packagist | All versions | 4.2.1 |

Products: Intelliants Subrion Cms.

## How do I fix CVE-2017-18366?

Upgrade intelliants/subrion to 4.2.1 or later.

## Is CVE-2017-18366 being exploited?

There is no known exploitation of CVE-2017-18366 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-11444](https://insights.sbomify.com/CVE-2017-11444/): SQL injection in n/a (critical 9.8)
- [CVE-2017-11445](https://insights.sbomify.com/CVE-2017-11445/): SQL injection in n/a (critical 9.8)
- [CVE-2017-6013](https://insights.sbomify.com/CVE-2017-6013/): SQL injection in n/a (critical 9.8)
- [CVE-2021-43464](https://insights.sbomify.com/CVE-2021-43464/): Remote code execution in Subrion (high 8.8)
- [CVE-2020-18326](https://insights.sbomify.com/CVE-2020-18326/): Cross Site Request Forgery in intelliants/subrion (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18366 and fix it if it is affected.

What it is: CVE-2017-18366 is a high-severity vulnerability in n/a, published on 12 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18366 in the wild and no public exploit code.

Affected packages and fixed versions:
- intelliants/subrion (Packagist): affected all versions; fixed in 4.2.1
- intelliants/subrion (Packagist): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18366/ (Markdown: https://insights.sbomify.com/CVE-2017-18366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18366
- OSV: https://osv.dev/vulnerability/CVE-2017-18366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18366/
Summaries are generated and may contain mistakes; the official description above is the record.
