# CVE-2017-18367: Improper Input Validation in libseccomp-golang

> Attackers can bypass seccomp restrictions by exploiting incorrect BPF generation in libseccomp-golang, allowing unauthorized syscall execution.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18367, DLA-2320-1, GHSA-58v3-j75h-xr49, GO-2020-0007, UBUNTU-CVE-2017-18367, USN-4574-1

## What is CVE-2017-18367?

CVE-2017-18367 is a high-severity vulnerability in n/a, published on 24 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libseccomp-golang 0.9.0 and earlier incorrectly generates BPFs that OR multiple arguments rather than ANDing them. A process running under a restrictive seccomp filter that specified multiple syscall arguments could bypass intended access restrictions by specifying a single matching argument.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-18367?

3 open source packages ship an affected version, including github.com/seccomp/libseccomp-golang. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/seccomp/libseccomp-golang` | Go | All versions | 0.9.1 |
| `github.com/seccomp/libseccomp-golang` | Go | All versions | 0.9.1 |
| `github.com/seccomp/libseccomp-golang` | Go | All versions | 0.9.1-0.20170424173420-06e7a29f36a3 |

Products: Libseccomp-Golang Project Libseccomp-Golang.

## How do I fix CVE-2017-18367?

Upgrade github.com/seccomp/libseccomp-golang to a fixed version for your release line: 0.9.1 or 0.9.1-0.20170424173420-06e7a29f36a3.

## Is CVE-2017-18367 being exploited?

There is no known exploitation of CVE-2017-18367 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18367 and fix it if it is affected.

What it is: CVE-2017-18367 is a high-severity vulnerability in n/a, published on 24 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18367 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/seccomp/libseccomp-golang (Go): affected all versions; fixed in 0.9.1
- github.com/seccomp/libseccomp-golang (Go): affected all versions; fixed in 0.9.1
- github.com/seccomp/libseccomp-golang (Go): affected all versions; fixed in 0.9.1-0.20170424173420-06e7a29f36a3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18367/ (Markdown: https://insights.sbomify.com/CVE-2017-18367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18367
- OSV: https://osv.dev/vulnerability/CVE-2017-18367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18367/
Summaries are generated and may contain mistakes; the official description above is the record.
