# CVE-2017-18513: Cross-site request forgery in n/a

> The responsive-menu WordPress plugin lacks CSRF protection in its admin interface, allowing attackers to perform unauthorized actions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rp58-q77j-6p9q

## What is CVE-2017-18513?

CVE-2017-18513 is a high-severity vulnerability in n/a, published on 14 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The responsive-menu plugin before 3.1.4 for WordPress has no CSRF protection mechanism for the admin interface.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-18513?

It affects 1 product.


Products: Expresstech Responsive Menu.

## How do I fix CVE-2017-18513?

No fix has been published for CVE-2017-18513 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-18513 being exploited?

There is no known exploitation of CVE-2017-18513 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-24160](https://insights.sbomify.com/CVE-2021-24160/): Responsive Menu 4.0.0 - 4.0.3 - Authenticated Arbitrary File Upload (high 8.8)
- [CVE-2021-24161](https://insights.sbomify.com/CVE-2021-24161/): Responsive Menu < 4.0.4 - CSRF to Arbitrary File Upload (high 8.8)
- [CVE-2021-24162](https://insights.sbomify.com/CVE-2021-24162/): Responsive Menu < 4.0.4 - CSRF to Settings Update (high 8.8)
- [CVE-2022-25602](https://insights.sbomify.com/CVE-2022-25602/): File upload in Responsive Menu (WordPress plugin) (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18513 and fix it if it is affected.

What it is: CVE-2017-18513 is a high-severity vulnerability in n/a, published on 14 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18513 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18513/ (Markdown: https://insights.sbomify.com/CVE-2017-18513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18513
- OSV: https://osv.dev/vulnerability/CVE-2017-18513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18513/
Summaries are generated and may contain mistakes; the official description above is the record.
