CVE-2017-18587 Headers containing newline characters can split messages in hyper
The hyper crate mishandles newlines in headers, potentially allowing HTTP request smuggling or header injection attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18587?
CVE-2017-18587 is a medium-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the hyper crate before 0.9.18 for Rust. It mishandles newlines in headers.
Weakness: CWE-93
Which versions are affected by CVE-2017-18587?
5 open source packages ship an affected version, including hyper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
hyper crates.io | All versions | 0.9.18 |
hyper crates.io | All versions | 0.9.18 |
hyper crates.io | From 0.0.0-0 | 0.9.18, 0.10.2 |
hyper crates.io | From 0.10.0 | 0.10.2 |
hyper crates.io | From 0.10.0 | 0.10.2 |
Products include Hyper Hyper.
How do I fix CVE-2017-18587?
Upgrade hyper to a fixed version for your release line: 0.9.18 or 0.10.2.
Is CVE-2017-18587 being exploited?
There is no known exploitation of CVE-2017-18587 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-35863 HTTP Request Smuggling in hyper
- CVE-2022-31394 Denial of service in n/a
- CVE-2021-32714 Integer Overflow in Chunked Transfer-Encoding
- CVE-2021-21299 Multiple Transfer-Encoding headers misinterprets request payload
- CVE-2016-10932 HTTPS MitM vulnerability due to lack of hostname verification
Sources
Also known as GHSA-q89x-f52w-6hj2, RUSTSEC-2017-0002.