CVE-2017-18589 Improper Input Validation in cookie
Attackers can cause a denial of service by sending cookies with large Max-Age values, crashing applications using the vulnerable Rust cookie library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18589?
CVE-2017-18589 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the cookie crate before 0.7.6 for Rust. Large integers in the Max-Age of a cookie cause a panic.
Weakness: CWE-20
Which versions are affected by CVE-2017-18589?
3 open source packages ship an affected version, including cookie. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cookie crates.io | All versions | 0.7.6 |
cookie crates.io | All versions | 0.7.6 |
cookie crates.io | From 0.6.0 | 0.6.2, 0.7.6 |
Products include Cookie Project Cookie.
How do I fix CVE-2017-18589?
Upgrade cookie to a fixed version for your release line: 0.7.6 or 0.6.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-18589 being exploited?
There is no known exploitation of CVE-2017-18589 in the wild and no public exploit code.
Sources
Also known as GHSA-vjrq-cg9x-rfjp, RUSTSEC-2017-0005.