{"answers":{"affected":"3 open source packages ship an affected version, including cookie. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-18589 in the wild and no public exploit code.","fix":"Upgrade cookie to a fixed version for your release line: 0.7.6 or 0.6.2.","what":"CVE-2017-18589 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18589 and fix it if it is affected.\n\nWhat it is: CVE-2017-18589 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18589 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cookie (crates.io): affected all versions; fixed in 0.7.6\n- cookie (crates.io): affected all versions; fixed in 0.7.6\n- cookie (crates.io): affected from 0.6.0; fixed in 0.6.2, 0.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18589/ (Markdown: https://insights.sbomify.com/CVE-2017-18589/index.md)","id":"CVE-2017-18589","markdown":"https://insights.sbomify.com/CVE-2017-18589/index.md","name":"CVE-2017-18589","record":{"aliases":["GHSA-vjrq-cg9x-rfjp","RUSTSEC-2017-0005"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust cookie library","requires_auth":"none","summary":"Attackers can cause a denial of service by sending cookies with large Max-Age values, crashing applications using the vulnerable Rust cookie library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cookie","vendor":"cookie_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in the cookie crate before 0.7.6 for Rust. Large integers in the Max-Age of a cookie cause a panic.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in cookie","id":"CVE-2017-18589","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-18590"},"packages":[{"ecosystem":"crates.io","fixed":["0.7.6"],"introduced":["0"],"last_affected":[],"package":"cookie","purl":null,"source":"GHSA-vjrq-cg9x-rfjp"},{"ecosystem":"crates.io","fixed":["0.7.6"],"introduced":["0"],"last_affected":[],"package":"cookie","purl":"pkg:cargo/cookie","source":"GHSA-vjrq-cg9x-rfjp"},{"ecosystem":"crates.io","fixed":["0.6.2","0.7.6"],"introduced":["0.6.0","0.7.0-0"],"last_affected":[],"package":"cookie","purl":"pkg:cargo/cookie","source":"RUSTSEC-2017-0005"}],"prev":{"headline":"Improper Certificate Validation in security-framework","id":"CVE-2017-18588"},"products":["n/a"],"published":"2019-08-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service by sending cookies with large Max-Age values, crashing applications using the vulnerable Rust cookie library.","url":"https://insights.sbomify.com/CVE-2017-18589/"}