# CVE-2017-18635: Cross-Site Scripting in @novnc/novnc

> A remote VNC server can inject arbitrary HTML into the noVNC web page via status messages, allowing cross-site scripting attacks against users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18635, DLA-1946-1, DLA-2854-1, GHSA-49rv-g7w5-m8xx, MGASA-2020-0374, RHSA-2020:0754, UBUNTU-CVE-2017-18635, USN-4522-1

## What is CVE-2017-18635?

CVE-2017-18635 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 25 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS vulnerability was discovered in noVNC before 0.6.2 in which the remote VNC server could inject arbitrary HTML into the noVNC web page via the messages propagated to the status field, such as the VNC server name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-18635?

2 open source packages ship an affected version, including @novnc/novnc. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@novnc/novnc` | npm | All versions | 0.6.2 |
| `@novnc/novnc` | npm | All versions | 0.6.2 |
| `novnc` | Red Hat:openstack:13::el7 | All versions | 0:1.1.0-2.el7ost |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Novnc Novnc, Redhat Openstack.

## How do I fix CVE-2017-18635?

Upgrade @novnc/novnc to 0.6.2 or later.

## Is CVE-2017-18635 being exploited?

There is no known exploitation of CVE-2017-18635 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2017-18635 (github_poc): https://github.com/ShielderSec/CVE-2017-18635

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18635 and fix it if it is affected.

What it is: CVE-2017-18635 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 25 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18635 in the wild and no public exploit code.

Affected packages and fixed versions:
- @novnc/novnc (npm): affected all versions; fixed in 0.6.2
- @novnc/novnc (npm): affected all versions; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18635/ (Markdown: https://insights.sbomify.com/CVE-2017-18635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18635
- OSV: https://osv.dev/vulnerability/CVE-2017-18635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18635/
Summaries are generated and may contain mistakes; the official description above is the record.
