# CVE-2017-18638: graphite.composer.views.send_email vulnerable to SSRF

> An attacker can exploit a Server-Side Request Forgery vulnerability in Graphite to exfiltrate sensitive data via email.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18638, DLA-1962-1, GHSA-vfj6-275q-4pvm, PYSEC-2019-151, SUSE-SU-2019:2803-1, UBUNTU-CVE-2017-18638

## What is CVE-2017-18638?

CVE-2017-18638 is a high-severity server-side request forgery vulnerability in n/a, published on 11 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

send_email in graphite-web/webapp/graphite/composer/views.py in Graphite through 1.1.5 is vulnerable to SSRF. The vulnerable SSRF endpoint can be used by an attacker to have the Graphite web server request any resource. The response to this SSRF request is encoded into an image file and then sent to an e-mail address that can be supplied by the attacker. Thus, an attacker can exfiltrate any information.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2017-18638?

3 open source packages ship an affected version, including graphite-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `graphite-web` | PyPI | All versions | 1.1.6 |
| `graphite-web` | PyPI | All versions | 1.1.6 |
| `graphite-web` | PyPI | All versions | 1.1.6 |
| `graphite-web` | SUSE:Enterprise Storage 4 | All versions | 0.9.12-5.3.1 |

Products: Graphite Project Graphite.

## How do I fix CVE-2017-18638?

Upgrade graphite-web to 1.1.6 or later.

## Is CVE-2017-18638 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18638 exists.

Public exploit code:

- Graphite <=1.1.5 - Server-Side Request Forgery (nuclei): http/cves/2017/CVE-2017-18638.yaml

## Other vulnerabilities in n/a

- [CVE-2013-5093](https://insights.sbomify.com/CVE-2013-5093/): graphite-web is vulnerable to Remote Code Execution via renderLocalView function (medium 6.8)
- [CVE-2013-5942](https://insights.sbomify.com/CVE-2013-5942/): graphite-web is vulnerable to Remote Code Execution (medium 6.8)
- [CVE-2013-5943](https://insights.sbomify.com/CVE-2013-5943/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2022-4728](https://insights.sbomify.com/CVE-2022-4728/): Graphite Web Cookie cross site scripting (low 3.5)
- [CVE-2022-4729](https://insights.sbomify.com/CVE-2022-4729/): Graphite Web Template Name cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18638 and fix it if it is affected.

What it is: CVE-2017-18638 is a high-severity server-side request forgery vulnerability in n/a, published on 11 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-18638 exists.

Affected packages and fixed versions:
- graphite-web (PyPI): affected all versions; fixed in 1.1.6
- graphite-web (PyPI): affected all versions; fixed in 1.1.6
- graphite-web (PyPI): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18638/ (Markdown: https://insights.sbomify.com/CVE-2017-18638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18638
- OSV: https://osv.dev/vulnerability/CVE-2017-18638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18638/
Summaries are generated and may contain mistakes; the official description above is the record.
