# CVE-2017-18640: SnakeYAML Entity Expansion during load operation

> Attackers can cause denial of service in applications using SnakeYAML by exploiting entity expansion during load operations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALSA-2020:4807, CLEANSTART-2026-CU41868, DEBIAN-CVE-2017-18640, GHSA-rvwf-54qp-4r6v, RHSA-2020:4807, RLSA-2020:4807, ROOT-APP-MAVEN-CVE-2017-18640, SUSE-SU-2021:1876-1, SUSE-SU-2021:1978-1, SUSE-SU-2021:1979-1, UBUNTU-CVE-2017-18640, USN-7368-1, openSUSE-SU-2021:0855-1, openSUSE-SU-2021:1876-1, openSUSE-SU-2024:11391-1

## What is CVE-2017-18640?

CVE-2017-18640 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Alias feature in SnakeYAML before 1.26 allows entity expansion during a load operation, a related issue to CVE-2003-1564.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2017-18640?

2 open source packages ship an affected version, including org.yaml:snakeyaml. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yaml:snakeyaml` | Maven | All versions | 1.26 |
| `org.yaml:snakeyaml` | Maven | All versions | 1.26 |
| `prometheus-jmx-exporter` | AlmaLinux:8 | All versions | 0.12.0-6.el8 |
| `prometheus-jmx-exporter` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.12.0-6.el8 |
| `prometheus-jmx-exporter` | Rocky Linux:8 | All versions | 0:0.12.0-6.el8 |
| `snakeyaml` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.28-3.5.1 |
| `snakeyaml` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.28-3.5.1 |
| `snakeyaml` | SUSE:Manager Server Module 4.0 | All versions | 1.28-12.3.1 |
| `snakeyaml` | SUSE:Manager Server Module 4.1 | All versions | 1.28-12.3.1 |
| `snakeyaml` | SUSE:Manager Server Module 4.2 | All versions | 1.28-3.5.1 |
| `snakeyaml` | openSUSE:Leap 15.2 | All versions | 1.28-lp152.2.3.1 |
| `snakeyaml` | openSUSE:Leap 15.3 | All versions | 1.28-3.5.1 |
| `snakeyaml` | openSUSE:Tumbleweed | All versions | 1.28-2.2 |

Products: Fedoraproject Fedora, Oracle Peoplesoft Enterprise Pt Peopletools, Quarkus Quarkus, Snakeyaml Project Snakeyaml.

## How do I fix CVE-2017-18640?

Upgrade org.yaml:snakeyaml to 1.26 or later.

## Is CVE-2017-18640 being exploited?

There is no known exploitation of CVE-2017-18640 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18640 and fix it if it is affected.

What it is: CVE-2017-18640 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18640 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.yaml:snakeyaml (Maven): affected all versions; fixed in 1.26
- org.yaml:snakeyaml (Maven): affected all versions; fixed in 1.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18640/ (Markdown: https://insights.sbomify.com/CVE-2017-18640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18640
- OSV: https://osv.dev/vulnerability/CVE-2017-18640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18640/
Summaries are generated and may contain mistakes; the official description above is the record.
