CVE-2017-18871 Mattermost Server vulnerable to Denial of Service through `@` character prefix inserted into JavaScript field names
Attackers can crash the Mattermost Server application by sending a specific input containing an @ character before a JavaScript field name.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18871?
CVE-2017-18871 is a high-severity denial of service vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.
Which versions are affected by CVE-2017-18871?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.2.2+incompatible, 4.3.4+incompatible, 4.4.5+incompatible, 4.5.0+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.2.2 |
github.com/mattermost/mattermost-server Go | All versions | 4.2.2 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.4 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.4 |
github.com/mattermost/mattermost-server Go | From 4.4.0-rc1 | 4.4.5 |
3 more packages
github.com/mattermost/mattermost-server Go | From 4.4.0-rc1 | 4.4.5 |
github.com/mattermost/mattermost-server Go | From 4.5.0-rc1 | 4.5.0 |
github.com/mattermost/mattermost-server Go | From 4.5.0-rc1 | 4.5.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18871?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.2.2+incompatible, 4.3.4+incompatible, 4.4.5+incompatible or 4.5.0+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-18871 being exploited?
There is no known exploitation of CVE-2017-18871 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-jc6w-8r7f-vmp5, GO-2025-4184.