CVE-2017-18872 Mattermost Server's OAuth 2.0 service is vulnerable to attack through Missing Authorization
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2017-18872?
CVE-2017-18872 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020.
Official description
An issue was discovered in Mattermost Server before 4.4.3 and 4.3.3. Attackers could reconfigure an OAuth app in some cases where Mattermost is an OAuth 2.0 service provider.
Weakness: CWE-732
Which versions are affected by CVE-2017-18872?
5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.3.3+incompatible, 4.4.3+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.3.3 |
github.com/mattermost/mattermost-server Go | All versions | 4.3.3 |
github.com/mattermost/mattermost-server Go | From 4.4.0-rc1 | 4.4.3 |
github.com/mattermost/mattermost-server Go | From 4.4.0-rc1 | 4.4.3 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18872?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.3.3+incompatible, 4.4.3+incompatible, 4.3.3 or 4.4.3.
Is CVE-2017-18872 being exploited?
There is no known exploitation of CVE-2017-18872 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-hgrp-fgm8-56g8, GO-2025-4075.