CVE-2017-18873 Mattermost Server is vulnerable to channel invisibility DoS via misformatted post
Attackers can cause denial of service by making channels invisible through misformatted posts in Mattermost Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18873?
CVE-2017-18873 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to cause a denial of service (channel invisibility) via a misformatted post.
Weakness: CWE-20
Which versions are affected by CVE-2017-18873?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171013141717-ee57a5829ab1+incompatible, 4.2.1-0.20171013140502-b3e4b0ac9168+incompatible, 4.3.0+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171013141717-ee57a5829ab1 |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171013141717-ee57a5829ab1 |
github.com/mattermost/mattermost-server Go | From 4.2.0 | 4.2.1-0.20171013140502-b3e4b0ac9168 |
github.com/mattermost/mattermost-server Go | From 4.2.0 | 4.2.1-0.20171013140502-b3e4b0ac9168 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18873?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2-0.20171013141717-ee57a5829ab1+incompatible, 4.2.1-0.20171013140502-b3e4b0ac9168+incompatible, 4.3.0+incompatible or 4.1.2-0.20171013141717-ee57a5829ab1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-18873 being exploited?
There is no known exploitation of CVE-2017-18873 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-x6mw-hf2j-vqpc, GO-2026-4282.