CVE-2017-18875 Mattermost Server does not prevent System Admin from arbitrary file creation
A system administrator can create arbitrary files when local storage is enabled, potentially leading to data modification or code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18875?
CVE-2017-18875 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2 when local storage for files is used. A System Admin can create arbitrary files.
Weakness: CWE-732
Which versions are affected by CVE-2017-18875?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171004201910-6be8113eb60c |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171004201910-6be8113eb60c |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1.0.20171004154238-fadd9514f6e7 | 4.2.1-0.20171004194140-6d3cb2ce07fc |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1.0.20171004154238-fadd9514f6e7 | 4.2.1-0.20171004194140-6d3cb2ce07fc |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1+incompatible | 4.3.0+incompatible |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18875?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2-0.20171004201910-6be8113eb60c, 4.2.1-0.20171004194140-6d3cb2ce07fc, 4.3.0 or 4.3.0+incompatible.
Is CVE-2017-18875 being exploited?
There is no known exploitation of CVE-2017-18875 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9rr5-q43r-ccv4, GO-2025-4186.