CVE-2017-18877 Mattermost Server is vulnerable to XSS attacks against an OAuth 2.0 allow/deny page

Medium 6.1 Published Updated

Cross-site scripting in Mattermost Server OAuth page allows attackers to execute scripts and potentially hijack user accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-18877?

CVE-2017-18877 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. XSS attacks could occur against an OAuth 2.0 allow/deny page.

Weakness: CWE-79

Which versions are affected by CVE-2017-18877?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible
github.com/mattermost/mattermost-server GoAll versions4.1.2
github.com/mattermost/mattermost-server GoAll versions4.1.2
github.com/mattermost/mattermost-server GoFrom 4.2.04.2.1
github.com/mattermost/mattermost-server GoFrom 4.2.04.2.1
github.com/mattermost/mattermost-server GoFrom 4.3.0-rc14.3.0
1 more packages
github.com/mattermost/mattermost-server GoFrom 4.3.0-rc14.3.0

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18877?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible or 4.1.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-18877 being exploited?

There is no known exploitation of CVE-2017-18877 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-9x8x-w6g5-hx4w, GO-2025-4190.

Is CVE-2017-18877 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free