CVE-2017-18878 Mattermost Server allows users with a session ID to revoke another users' session
Attackers can revoke other users' sessions by knowing their session IDs, leading to unauthorized access or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18878?
CVE-2017-18878 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. Knowledge of a session ID allows revoking another user's session.
Weakness: CWE-732
Which versions are affected by CVE-2017-18878?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171004201910-6be8113eb60c |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2-0.20171004201910-6be8113eb60c |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.1-0.20171004192657-8fbbd688ea24 |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.1-0.20171004192657-8fbbd688ea24 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1+incompatible | 4.3.0+incompatible |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18878?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2-0.20171004201910-6be8113eb60c, 4.2.1-0.20171004192657-8fbbd688ea24, 4.3.0 or 4.3.0+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-18878 being exploited?
There is no known exploitation of CVE-2017-18878 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-h564-6gc2-fcc6, GO-2025-4191.