CVE-2017-18883 Mattermost Server has low entropy for authorization data as an OAuth 2.0 Service Provider

Critical 9.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2017-18883?

CVE-2017-18883 is a critical vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020.

Official description

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2, when serving as an OAuth 2.0 Service Provider. There is low entropy for authorization data.

Weakness: CWE-331

Which versions are affected by CVE-2017-18883?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible
github.com/mattermost/mattermost-server GoAll versions4.1.2
github.com/mattermost/mattermost-server GoAll versions4.1.2
github.com/mattermost/mattermost-server GoFrom 4.2.0-rc14.2.1
github.com/mattermost/mattermost-server GoFrom 4.2.0-rc14.2.1
github.com/mattermost/mattermost-server GoFrom 4.3.0-rc14.3.0
1 more packages
github.com/mattermost/mattermost-server GoFrom 4.3.0-rc14.3.0

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18883?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible or 4.1.2.

Is CVE-2017-18883 being exploited?

There is no known exploitation of CVE-2017-18883 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-w8cc-3h7q-jhc3, GO-2025-4198.

Is CVE-2017-18883 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free