CVE-2017-18884 Mattermost Server exposes OAuth personal access tokens to attackers
Attackers can escalate privileges in Mattermost Server by exploiting registered OAuth applications with personal access tokens.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18884?
CVE-2017-18884 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to gain privileges by using a registered OAuth application with personal access tokens.
Weakness: CWE-269
Which versions are affected by CVE-2017-18884?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2 |
github.com/mattermost/mattermost-server Go | All versions | 4.1.2 |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.1 |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.1 |
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.3.0-rc1 | 4.3.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18884?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.1.2+incompatible, 4.2.1+incompatible, 4.3.0+incompatible or 4.1.2.
Is CVE-2017-18884 being exploited?
There is no known exploitation of CVE-2017-18884 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-876j-jfqf-m7j7, GO-2025-4197.