CVE-2017-18893 Mattermost Server is vulnerable to XSS through display name field
An attacker can inject malicious scripts via display names in Mattermost Server, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-18893?
CVE-2017-18893 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5. Display names allow XSS.
Weakness: CWE-79
Which versions are affected by CVE-2017-18893?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.0.5 |
github.com/mattermost/mattermost-server Go | All versions | 4.0.5 |
github.com/mattermost/mattermost-server Go | From 4.1.0 | 4.1.1 |
github.com/mattermost/mattermost-server Go | From 4.1.0 | 4.1.1 |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18893?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible or 4.0.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-18893 being exploited?
There is no known exploitation of CVE-2017-18893 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-887v-xh2x-47cm, GO-2026-4296.