CVE-2017-18894 Mattermost Server has intermittent Authorization bypass for resource-owners

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2017-18894?

CVE-2017-18894 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020.

Official description

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5, when used as an OAuth 2.0 service provider. Sometimes. resource-owner authorization is bypassed, allowing account takeover.

Weakness: CWE-732

Which versions are affected by CVE-2017-18894?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible
github.com/mattermost/mattermost-server GoAll versions4.0.5
github.com/mattermost/mattermost-server GoAll versions4.0.5
github.com/mattermost/mattermost-server GoFrom 4.1.04.1.1
github.com/mattermost/mattermost-server GoFrom 4.1.04.1.1
github.com/mattermost/mattermost-server GoFrom 4.2.0-rc14.2.0
1 more packages
github.com/mattermost/mattermost-server GoFrom 4.2.0-rc14.2.0

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18894?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible or 4.0.5.

Is CVE-2017-18894 being exploited?

There is no known exploitation of CVE-2017-18894 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-gg42-mwr6-p82c, GO-2026-4297.

Is CVE-2017-18894 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free