CVE-2017-18898 Mattermost Server is vulnerable to DoS through maliciously crafted posts
Crafted posts in Mattermost Server can cause web browsers to hang, resulting in a denial of service for users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18898?
CVE-2017-18898 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5. It allows crafted posts that potentially cause a web browser to hang.
Weakness: CWE-404
Which versions are affected by CVE-2017-18898?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 4.0.5 |
github.com/mattermost/mattermost-server Go | All versions | 4.0.5 |
github.com/mattermost/mattermost-server Go | From 4.1.0 | 4.1.1 |
github.com/mattermost/mattermost-server Go | From 4.1.0 | 4.1.1 |
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.0 |
1 more packages
github.com/mattermost/mattermost-server Go | From 4.2.0-rc1 | 4.2.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18898?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible or 4.0.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-18898 being exploited?
There is no known exploitation of CVE-2017-18898 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9589-mq83-f749, GO-2026-4300.