CVE-2017-18900 Mattermost Server is vulnerable CSV Injection

Critical 9.8 Published Updated

Attackers can inject malicious formulas into CSV compliance reports, potentially leading to code execution when the file is opened in spreadsheet software.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-18900?

CVE-2017-18900 is a critical code injection vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. It allows CSV injection via a compliance report.

Weakness: CWE-74

Which versions are affected by CVE-2017-18900?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions3.10.3+incompatible, 4.0.3+incompatible
github.com/mattermost/mattermost-server GoAll versions3.10.3
github.com/mattermost/mattermost-server GoAll versions3.10.3
github.com/mattermost/mattermost-server GoFrom 4.0.04.0.3
github.com/mattermost/mattermost-server GoFrom 4.0.04.0.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18900?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.10.3+incompatible, 4.0.3+incompatible, 3.10.3 or 4.0.3.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2017-18900 being exploited?

There is no known exploitation of CVE-2017-18900 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-8q4v-35v6-g8wr, GO-2026-4303.

Is CVE-2017-18900 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free