CVE-2017-18903 Mattermost Server vulnerable to CSRF if CORS is enabled

High 8.8 Published Updated

Attackers can perform cross-site request forgery if CORS is enabled, allowing unauthorized actions on behalf of users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-18903?

CVE-2017-18903 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. CSRF can occur if CORS is enabled.

Weakness: CWE-352

Which versions are affected by CVE-2017-18903?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions3.9.2+incompatible, 3.10.2+incompatible
github.com/mattermost/mattermost-server GoAll versions3.9.2
github.com/mattermost/mattermost-server GoAll versions3.9.2
github.com/mattermost/mattermost-server GoFrom 3.10.0-rc13.10.2
github.com/mattermost/mattermost-server GoFrom 3.10.0-rc13.10.2

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18903?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.9.2+incompatible, 3.10.2+incompatible, 3.9.2 or 3.10.2.

Is CVE-2017-18903 being exploited?

There is no known exploitation of CVE-2017-18903 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-fcwg-45jh-5qhf, GO-2026-4305.

Is CVE-2017-18903 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free