CVE-2017-18904 Mattermost Server vulnerable to XSS via an uploaded file
An attacker can execute arbitrary scripts in the context of other users via a maliciously uploaded file in Mattermost Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-18904?
CVE-2017-18904 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. It allows XSS via an uploaded file.
Weakness: CWE-79
Which versions are affected by CVE-2017-18904?
5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 3.9.2+incompatible, 3.10.2+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 3.9.2 |
github.com/mattermost/mattermost-server Go | All versions | 3.9.2 |
github.com/mattermost/mattermost-server Go | From 3.10.0 | 3.10.2 |
github.com/mattermost/mattermost-server Go | From 3.10.0 | 3.10.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18904?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.9.2+incompatible, 3.10.2+incompatible, 3.9.2 or 3.10.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-18904 being exploited?
There is no known exploitation of CVE-2017-18904 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-8pff-p3gx-w4jf, GO-2026-4302.