CVE-2017-18905 Mattermost Server has Insufficient Session Expiration when used as an OAuth 2.0 service provider

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2017-18905?

CVE-2017-18905 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020.

Official description

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when used as an OAuth 2.0 service provider, Session invalidation was mishandled.

Weakness: CWE-613

Which versions are affected by CVE-2017-18905?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions3.9.2+incompatible, 3.10.2+incompatible
github.com/mattermost/mattermost-server GoAll versions3.9.2
github.com/mattermost/mattermost-server GoAll versions3.9.2
github.com/mattermost/mattermost-server GoFrom 3.10.03.10.2
github.com/mattermost/mattermost-server GoFrom 3.10.03.10.2

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18905?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.9.2+incompatible, 3.10.2+incompatible, 3.9.2 or 3.10.2.

Is CVE-2017-18905 being exploited?

There is no known exploitation of CVE-2017-18905 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-g24c-fx4v-xg9w, GO-2026-4306.

Is CVE-2017-18905 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free