{"answers":{"affected":"5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-18908 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.9.1-rc1+incompatible, 3.10.1+incompatible, 3.9.1-rc1 or 3.10.1.","what":"CVE-2017-18908 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18908 and fix it if it is affected.\n\nWhat it is: CVE-2017-18908 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.9.1-rc1+incompatible, 3.10.1+incompatible\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.9.1-rc1\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.9.1-rc1\n- github.com/mattermost/mattermost-server (Go): affected from 3.10.0; fixed in 3.10.1\n- github.com/mattermost/mattermost-server (Go): affected from 3.10.0; fixed in 3.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18908/ (Markdown: https://insights.sbomify.com/CVE-2017-18908/index.md)","id":"CVE-2017-18908","markdown":"https://insights.sbomify.com/CVE-2017-18908/index.md","name":"CVE-2017-18908","record":{"aliases":["GHSA-34cx-hvm4-vx7j","GO-2026-4476"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Server","requires_auth":"none","summary":"Attackers can hijack accounts by receiving password reset emails sent to attacker-controlled addresses due to improper validation.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. A password-reset request was sometime sent to an attacker-provided e-mail address.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mattermost Server password reset email requests can be sent to attacker-provided email addresses","id":"CVE-2017-18908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"auth_bypass","year":"2017"},"n_packages":5,"n_references":1,"next":{"headline":"Mattermost Server SAML implementation does not require encryption or signature verification as default","id":"CVE-2017-18909"},"packages":[{"ecosystem":"Go","fixed":["3.9.1-rc1+incompatible","3.10.1+incompatible"],"introduced":["0","3.10.0+incompatible"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GO-2026-4476"},{"ecosystem":"Go","fixed":["3.9.1-rc1"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":null,"source":"GHSA-34cx-hvm4-vx7j"},{"ecosystem":"Go","fixed":["3.9.1-rc1"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GHSA-34cx-hvm4-vx7j"},{"ecosystem":"Go","fixed":["3.10.1"],"introduced":["3.10.0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":null,"source":"GHSA-34cx-hvm4-vx7j"},{"ecosystem":"Go","fixed":["3.10.1"],"introduced":["3.10.0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GHSA-34cx-hvm4-vx7j"}],"prev":{"headline":"Mattermost Server vulnerable to XSS through channel headers","id":"CVE-2017-18907"},"products":["n/a"],"published":"2020-06-19","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can hijack accounts by receiving password reset emails sent to attacker-controlled addresses due to improper validation.","url":"https://insights.sbomify.com/CVE-2017-18908/"}