CVE-2017-18911 Mattermost Server has X.509 Improper Certificate Validation
Attackers can bypass X.509 certificate validation for TLS-based email servers, allowing potential man-in-the-middle attacks on email communications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18911?
CVE-2017-18911 is a critical vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. The X.509 certificate validation can be skipped for a TLS-based e-mail server.
Weakness: CWE-295
Which versions are affected by CVE-2017-18911?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 3.6.7-rc1+incompatible, 3.7.5+incompatible, 3.8.2+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 3.6.7-rc1 |
github.com/mattermost/mattermost-server Go | All versions | 3.6.7-rc1 |
github.com/mattermost/mattermost-server Go | From 3.7.0 | 3.7.5 |
github.com/mattermost/mattermost-server Go | From 3.7.0 | 3.7.5 |
github.com/mattermost/mattermost-server Go | From 3.8.0 | 3.8.2 |
1 more packages
github.com/mattermost/mattermost-server Go | From 3.8.0 | 3.8.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18911?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.6.7-rc1+incompatible, 3.7.5+incompatible, 3.8.2+incompatible or 3.6.7-rc1.
Is CVE-2017-18911 being exploited?
There is no known exploitation of CVE-2017-18911 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-m462-mqw4-2c8m, GO-2026-4464.