CVE-2017-18915 Mattermost Server server restarts may provide attackers with API access
Attackers can gain unauthorized API endpoint access after a server restart due to improper authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-18915?
CVE-2017-18915 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. After a restart of a server, an attacker might suddenly gain API Endpoint access.
Weakness: CWE-276
Which versions are affected by CVE-2017-18915?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 3.6.7-0.20170420152529-0968e4079e0a |
github.com/mattermost/mattermost-server Go | All versions | 3.6.7-0.20170420152529-0968e4079e0a |
github.com/mattermost/mattermost-server Go | From 3.7.0 | 3.7.5 |
github.com/mattermost/mattermost-server Go | From 3.7.0 | 3.7.5 |
github.com/mattermost/mattermost-server Go | From 3.7.0+incompatible | 3.7.5+incompatible, 3.8.2+incompatible |
github.com/mattermost/mattermost-server Go | From 3.8.0 | 3.8.2 |
1 more packages
github.com/mattermost/mattermost-server Go | From 3.8.0 | 3.8.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2017-18915?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.7.5+incompatible or 3.8.2+incompatible.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-18915 being exploited?
There is no known exploitation of CVE-2017-18915 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-hxxj-8phw-74vw, GO-2026-4462.