CVE-2017-18916 Mattermost Server has Improper Authorization for Integration Requests

Medium 5.3 Published Updated

Attackers can bypass integration permission restrictions on API endpoints, potentially accessing unauthorized features in Mattermost Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-18916?

CVE-2017-18916 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. API endpoint access control does not honor an integration permission restriction.

Weakness: CWE-732

Which versions are affected by CVE-2017-18916?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions3.6.7-0.20170420152529-0968e4079e0a
github.com/mattermost/mattermost-server GoAll versions3.6.7-0.20170420152529-0968e4079e0a
github.com/mattermost/mattermost-server GoFrom 3.7.03.7.5
github.com/mattermost/mattermost-server GoFrom 3.7.03.7.5
github.com/mattermost/mattermost-server GoFrom 3.7.0+incompatible3.7.5+incompatible, 3.8.2+incompatible
github.com/mattermost/mattermost-server GoFrom 3.8.03.8.2
1 more packages
github.com/mattermost/mattermost-server GoFrom 3.8.03.8.2

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18916?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.7.5+incompatible or 3.8.2+incompatible.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2017-18916 being exploited?

There is no known exploitation of CVE-2017-18916 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-x33g-375j-jhf7, GO-2026-4467.

Is CVE-2017-18916 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free